PS4 Hack'lendi; Geriye Uyumlu Oldu!

PlayStation 4, hacker'ların keşfettiği yeni açık sayesinde geriye uyumluluk kazanabiliyor!

  • H. Hüseyin Öztürk
PS4 Hack'lendi; Geriye Uyumlu Oldu!

Ekim 2016'da, Şangay'daki GeekPwn konferansında hacker'lar, 4.01 firmware sürümüne sahip PlayStation 4'lere Linux yüklenmesine izin veren bir güvenlik açığı keşfetmişti. Webkit güvenlik açığı, hacker'ların hedef sisteme kötü niyetli kodlar enjekte etmesine izin veriyordu. 

Şimdi ise firmware'nin 4.05 sürümünü çalıştıran sistemlere has yeni bir güvenlik açığı, hacker'lara sınırsız, alt-seviye erişim tanıyor. Neyse ki bu açık sadece eski bir sistem yazılımını kullanan cihazlarda var (en son firmware sürümü 5.05'e ulaştı), bu sayede güvenlik açığı pek yayılamıyor.

İşin ilginç yanı ise bu güvenlik açığı sayesinde normalde PS2 oyunları için geri uyumluluğu olmayan PS4'e, bu oyunları çalıştırma özelliğinin getirilebilmesi.

PS4 ilk çıktığında Sony, sistemin hiçbir eski konsolla geri uyumlu olmayacağını söylemişti. Buna rağmen bazı çok popüler PS2 oyunlarını ya PlayStation Now aracılığıyla ya da mağazasında yeniden yayınlayarak çıkardı.

Ama bu arşiv oldukça kısıtlıydı. Bu yüzden, hacker'ların kullandığı bu güvenlik açığı ile çok daha fazla PS2 oyunu için geri uyumluluk mümkün olabiliyor.

Bunun yanında, bu durumdan faydalanabilmek için eski firmware kullanmak gerektiği için, PS4 oyunları oynamak sorunlu olabiliyor çünkü PlayStation Network, en güncel sistem firmware'ni kullanmanızı zorunlu kılıyor.

Okuyucu Yorumları

İlk yorum yapan siz olun
Sen de yorum yaz

 

CHIP'i Takip edin
E-Posta listemize katılın
CHIP Dergi Mobil Cihazınızda
Apple Store
Google Play

Turhost

İlginizi çekebilir

 

 

Turhost